HK radio issues

  • Help support Chopped Baggers :

Buggy

One of THE 150!
Messages
1,279
Location
Pittsburgh Pa
While I was out yestarday my radio quit working several times, all hand controls and display worked fine just no sound. I powered off radio and then back on then it worked several times. Any one else with this issue?
 

thecort

Well-Known Member
Messages
5,062
Location
NYC
Yes. It'll only get worse. You can send it out to have it repaired or just replace it with another head unit.

What you should do is get it replaced under warranty, then sell the new one. You'll get a pretty penny for it. That $$ can go to your new system!

Tap it!
 
Last edited:

Buggy

One of THE 150!
Messages
1,279
Location
Pittsburgh Pa
Always wanted one, I have had 3 SG and some sort of radio issue with each one. I only got the last 2 cuz wifey likes music,
 

thecort

Well-Known Member
Messages
5,062
Location
NYC
Well, if you don't care for tunes while you ride then I can understand. If you really like them, then sell the HK & upgrade. JMO


Tap it!
 

thecort

Well-Known Member
Messages
5,062
Location
NYC
Just don't put it that way to her or she may say she wants to go bigger too! lol


Tap it!
 

thecort

Well-Known Member
Messages
5,062
Location
NYC
Yep. J&M Rokker 500W 4ch. No problems at all. Very happy with it. I don't care for their speakers at all, though.


Tap it!
 

thecort

Well-Known Member
Messages
5,062
Location
NYC
The speakers aren't bad. They're just not as good as J&M leads you to believe. They sound good by themselves. But when you play them next to another set they just don't perform as well.


Tap it!
 

ramnj

One of THE 150!
Messages
1,037
Location
NJ
While I was out yestarday my radio quit working several times, all hand controls and display worked fine just no sound. I powered off radio and then back on then it worked several times. Any one else with this issue?

I had the same issue last week. Stopped working, drove about 20 minutes and stopped to fuel up and when I started the bike again the radio was working like nothing happened. It has not happened again so I thought is was a hiccup. I guess time will tell. My luck, the factory warranty just expired in March.
 
Top