• Hello there Guest! Welcome to ChoppedBaggers.com, why not introduce yourself to the group in the Introduction forum, click here!

23 Conversion issues

13yellowglide

Well-Known Member
Messages
53
I hope to get some inste on the problem I discovered when riding my bike for the first time after performing a 23 install on my 2013 Street Glide. 1st off when I last rode I was rolling 19 front and 18 rear with no problems. I had already installed Ness 7 and 7 trees and Legend Axeo front cartrage’s for the 23. When riding yesterday everything started good. City riding was fine no issues lights or codes. On the hiway after. About 45 min noticed abs light on then 10 min later the security key was on. Then felt the bike start dragging like brakes were applying. Front brake handle hard as a rock at this point slow down a bit using front and rear brake it seemed to release and return to normal other than the lights. I stopped and removed abs fuse thinking abs was trying to apply brakes seemed to solve problem for 1st 20 min then it all started again. I looked down and looked as if front pads were glowing but rotor was not. Grab front brake hard again slow down it went soft again this time like it had an open brake line all way to the grip. No leaks it does have abs with correct bearings. I am a master mechanic for 26 years have always done my own work but his has me baffeled. Any help would be great if anyone still reads the post on this form.


Captain

Vice President
Guardians Of The Children Chisholm Trail
 

Marc

""The Chopped Baggers Guy""
Messages
12,446
Abs bearing is no good change it


Sent from my iPhone using Tapatalk
 

13yellowglide

Well-Known Member
Messages
53
Working on that now installing a ness bearing for 23 only. By chance do you know the hub torque on a jade wheel?


Captain

Vice President
Guardians Of The Children Chisholm Trail
 

Marc

""The Chopped Baggers Guy""
Messages
12,446
I always torqued renegades to 65 with red lock tight


Sent from my iPhone using Tapatalk
 

gasman1620

Well-Known Member
Messages
48
I'm not sure if the 23 is big enough, but the increased wheel diameter on my 26 caused the ABS system to malfunction. You need to get the trackmax module to correct the issue.
 

Marc

""The Chopped Baggers Guy""
Messages
12,446
No need for a tracmax those are outdated
Mcbagger makes 23,26,30,32 and 34 bearings. Bout $50


Sent from my iPhone using Tapatalk
 

13yellowglide

Well-Known Member
Messages
53
I installed a. 23 bearing from Ness wrapping up some electrical and will know if it corrected the problem. Most likely it will since It was not reading a front wheel speed signal. All wiring checks ok.


Captain

Vice President
Guardians Of The Children Chisholm Trail
 

Marc

""The Chopped Baggers Guy""
Messages
12,446
How did that work? I’ve had no luck at all with ness bearings. I’ve went 3 for 3 junk so I only use mc baggers now.


Sent from my iPhone using Tapatalk
 

13yellowglide

Well-Known Member
Messages
53
So far so good with the signal loss of front sensor issue. Brakes are solid now no dragging or trying to apply.Now Getting an intermittent loss of serial data that I’m tracking down. Told the wife the bike is mad at me for not riding her for six months.


Captain

Vice President
Guardians Of The Children Chisholm Trail
 

DanHappy

Well-Known Member
Messages
508
Please keep us posted. Be curious what the final problem is.

Sent from my Note 4 using Tapatalk
 

Latest posts

Top