07 street glide cd player issue

  • Help support Chopped Baggers :

built

One of THE 150!
Messages
51
Location
Detroit
since day one my stock cd player skips like crazy over 70-80mph. radio works fine as well as aux and i can't figure it out. i replaced all the broken fairing brackets. used the updated speaker brackets and 90* 1/8" steel elbows so the fairing brackets will never break again. now i have the J&M audio speakers and a new HARMAN KARDON RADIO AND IT STILL SKIPS!?!?! what gives?
 

built

One of THE 150!
Messages
51
Location
Detroit
it's gotta be something im missing. it does it with two different units on my bike. none of my friends have this issue and my buddy i got the second cd player from had zero issues with it on his bike
 

Peterod45

Well-Known Member
Messages
346
Location
Castaic, CA
Strange. I rode my brothers'06 SG over the weekend and over 80 the cd just stopped working. I asked him about it, and he said it skips over 70-75 all the time. That's BS!

Plus, you have an '07 w a 6 speed, so I doubt it's the vibes. Hmmmmm...
 

bradwulf20

Well-Known Member
Messages
435
Location
south dakota
you could also go aftermarket. depending what you are looking for. medalion make an excelent replacement with no moving parts to malfunction due to the vibration that we all know every harley creates
 

slothy

Balls
Messages
7,352
Location
St. Clair Shore, Mi
wasn't there a issue at one point with something touching, upper clamp or something causing more vibration on the radio then normal? i remember seeing something on the hd forums awhile ago.
 

built

One of THE 150!
Messages
51
Location
Detroit
I have two hk radios and it does it with both. I'm thinking it could be something I'm missing? Bushings on the bracket? Idk
 
Top